Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0

Slow mission speed


Zerath

Question

2 answers to this question

Recommended Posts

  • 0

The slowness you're experiencing is usually caused by poor performance, more with the game than hardware in a lot of cases. Despite being an old game, PSU still requires a fairly fast running CPU to maintain smooth 60FPS without slow down. There are a few things you can try though:

If you have a multicore CPU then you can set CPU Affinity. After connecting (that is, selecting your character and entering the lobby), you can set your core affinity via the task manager (Ctrl + Shift + Esc to avoid game crashing).
Go to Details
Find PSUC.exe
Right-click and select Set Affinity.
You can set this to All, or at least 2 cores that aren't Hyper Threaded.
 

If that doesn't work then you can also set the game to Frame Skip 1 in the launchers Options menu. This will make the game run at 30, which isn't great, but it may help resolve the issue. 

Link to post
Share on other sites
  • 0
16 hours ago, Marmalade said:

The slowness you're experiencing is usually caused by poor performance, more with the game than hardware in a lot of cases. Despite being an old game, PSU still requires a fairly fast running CPU to maintain smooth 60FPS without slow down. There are a few things you can try though:

If you have a multicore CPU then you can set CPU Affinity. After connecting (that is, selecting your character and entering the lobby), you can set your core affinity via the task manager (Ctrl + Shift + Esc to avoid game crashing).
Go to Details
Find PSUC.exe
Right-click and select Set Affinity.
You can set this to All, or at least 2 cores that aren't Hyper Threaded.
 

If that doesn't work then you can also set the game to Frame Skip 1 in the launchers Options menu. This will make the game run at 30, which isn't great, but it may help resolve the issue. 

Me being me I forgot I had recently made my background a moving one with music that plays with it. When I switched the background off the games runs 100% now. So all is good! Was a simple fix! Thanks for the info for a future reference if need be!!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...