Jump to content
bando_boyッ

Xbox 360/Xbox One Controller Setup (restore triggers/vibration)

Recommended Posts

A quick guide on how to setup Xbox 360/Xbox One controllers on Clementine.

**Updated for launch**


This is perfect for people who don't care to use joy2key.

This guide will restore trigger function and even enable rumble without having to load additional programs alongside Clementine.
**Only the initial XInputPlus setup, won't have to run ever again!

1. Download
Xinput Plushttps://drive.google.com/drive/folders/1xwOe7D5iSy-8EtJI5_bHWtzL9hMr9pFO?usp=sharing (safe upload from my own google drive)
2. Extract to wherever you want, then run "
XInputPlus.exe" as admin
3. Next to the target program tab, click "
Select", then go to your Clementine install directory and select "PSUC.exe"
4. Now click on the "
DirectInput Tab", click "Enable DirectInput Output", and set "LT/RT" as "Button 11/12"
5. Click "
Apply" at the bottom of the program, and now XInputPlus is configured properly!
6. Run "
online.exe" as admin and click through the following steps: Options>Game pad settings>Default pattern 2
7. Finally, set "Page left" as LT (Button 11) and "Page right, Chat Log" as RT (Button 12)

Now your Xbox 360/Xbox One controller is properly configured and fully working for Clementine!

xinput plus settings.png

game pad configuration.png

Share this post


Link to post
Share on other sites

Thats cool solution. Highly customizable tool, with switches, sensitivity adjustment, literally allows to solve all most popular gamepad problems. Thank you for this info. I've heard about it before of course, but never tried until now.

Share this post


Link to post
Share on other sites
11 hours ago, AnamanaAU said:

Tried using this setup, but it forced the camera to keep rotating. Is there a way around this?

Same problem here T-T

Share this post


Link to post
Share on other sites

same problem as above, just spinning.

my right stick is  -7% and -9% on output and input.

Do i just move the output to 0?

Edited by Deezz

Share this post


Link to post
Share on other sites
7 hours ago, bando_boyッ said:

it's not a xinput problem i don't think, i've never had that happen. i think the options in the launcher are mapped wrong for camera options.

That might be what it is, because my dead zones are perfect. I ran the tests and everything.

Share this post


Link to post
Share on other sites

I tried this with a imput mapper (PS4 controller via blue tooth) & it wont even notice the controller what so ever. Tested it out on other games & it work fine. PSU however, with of without this guide its the same results. if anyone figures this out it would be of a great help as the keyboard controls for PSU are so bad.

Share this post


Link to post
Share on other sites

I'm trying to get this to work with a Steam Controller. (It's an even bigger nightmare, I know.) And I also have the spinning camera problem. 😕

Share this post


Link to post
Share on other sites
26 minutes ago, Karma 12 said:

I'm trying to get this to work with a Steam Controller. (It's an even bigger nightmare, I know.) And I also have the spinning camera problem. 😕

Just to save you some headache, don't bother trying to run a Steam controller unless you have a special program for it. Its built in such a way that it doesn't work properly without the Steam API essentially mapping the output from the controller from being mostly rubbish to actual acceptable input. Not sure if this was some cost saving measure by Valve or it was done to make the controller only proprietarily work with *their* stuff but I ran into a similar issue when I tried to use it on mobile and this was the wall I ran into. Its basically an empty husk with buttons without the Steam API pushing it.

Share this post


Link to post
Share on other sites
3 minutes ago, Yasha said:

Just to save you some headache, don't bother trying to run a Steam controller unless you have a special program for it. Its built in such a way that it doesn't work properly without the Steam API essentially mapping the output from the controller from being mostly rubbish to actual acceptable input.

Yeah, normally you can get it to work by running the game through Steam but no luck this time...

Share this post


Link to post
Share on other sites
1 minute ago, Karma 12 said:

Yeah, normally you can get it to work by running the game through Steam but no luck this time...

Ah okay, I had seen people mention that method on Reddit for some games but I hadn't seen anyone mention it being successful so I wasn't sure if it actually worked. Worst come to shove, I've also found pretty decent success with a program called XPadder as well though I don't know how well it would work with a Steam controller.

Share this post


Link to post
Share on other sites

Worked like a charm for microsoft brand wired xbox 360 controller. However, I still cant figure out, on the bottom left the thing that is marked Z to toggle the little end mission reward. Nothing works except Z, I assume this is supposed to be right trigger??? Also cant figure out how to bring up the taunt / action menu. 

edit- the action menu is actually X button. It seems its bound RT to button 11 and LT is missing in action.

edit 2- I redid the xinput program and it just worked this time. 

Edited by Syddhartha

Share this post


Link to post
Share on other sites

Wanted to pop in a reply here from a PS4 controller user finding success with this. did everything the OP says to do. however I right clicked my xinput > properties > compatability > clicked the box run as admin. 
I'm also using ds4 windows program which makes my pad register as a 360 pad. using ps4 wireless with bluetooth. Everything is working perfect now. the triggers are working just like this did on xbox 360.  Left and Right triggers / L2/R2 now go to item or weapon pallet and scroll etc, I can hold R2 for doing alt gender emotes, and L2 checks mails, pt inv etc etc. 

I haven't seen anyone posting success with a ps4 pad so just wanted to inform this does indeed work with ds4 windows.

Thanks a bunch for sharing this great fix!

Edited by Lil Ms Thunda Thighs

Share this post


Link to post
Share on other sites

Did everything in this topic here but now I'm stuck at the end part where you have to confirm your settings within the options, since I use a custom resolution the built in resolution option is blank and will not allow me to confirm the changes I made without changing the resolution within it which is impossible due to it being nothing in the box.

Share this post


Link to post
Share on other sites

Thank-you for this fix! I did have some troubles getting my controller to work, even after applying this fix.

When I tried it, my controller went 'dead', as in none of the inputs registered. I tried to  run the xinputplus thing again, since some people have had luck with that, and still nothing. So I unplugged other controllers, and found my x360 controller working, and heard that loud sound from (I assume) Xinput+.

Everything was working fine, it read my controller, it worked perfectly on PSU, however, I wondered if there was a way to keep all my controllers plugged in. I checked the folder and saw Dinput8.dll and it reminded me of devreorder. Two tests later, I found that doing this guide works (single controller), then do the devreorder (for multi controller fans, like me).

Maybe it's a little extra step, maybe it might help someone!

Share this post


Link to post
Share on other sites

To those wanting a more visual tutorial I just got done creating a video on how to set this up. Don't worry, I didn't just try to steal BANDO_BOY's idea, I've actually been wanting to make video for over a year now, and this post gave me the inspiration to do so. I even credited him in the video.

https://youtu.be/Y7pLUQiCZLo

Hope you guys enjoy it! :)

Share this post


Link to post
Share on other sites
9 hours ago, TC74 said:

Did everything in this topic here but now I'm stuck at the end part where you have to confirm your settings within the options, since I use a custom resolution the built in resolution option is blank and will not allow me to confirm the changes I made without changing the resolution within it which is impossible due to it being nothing in the box.

A workaround for this is to go back to defaults for PSU, finish setting up XInput, and then reapply your custom resolution. Also something I noticed is if ''screen color'' is set for 16bit, the resolution option goes blank. Set that for 32bit.

Share this post


Link to post
Share on other sites

on the launcher game option the controls won't save when i config button 11 and 12 any fix?

 

Edited by MrNobody498

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...